新手必看

新手必看

常见问题必读帮助文件
鸿宇官网

鸿宇官网

鸿宇科技官方网站
鸿宇教程库

鸿宇教程库

鸿宇科技官方教程
功能反馈与建议

功能反馈与建议

BUG反馈问题建议
鸿宇淘宝店铺

鸿宇淘宝店铺

鸿宇官方唯一淘宝店铺
旺迈特官网

旺迈特官网

B2B2C新零售智慧生态电商系统
旺迈特演示站点

旺迈特演示站点

新零售智慧生态电商系统
QQ在线客服

QQ在线客服

程序二次开发/功能定制/系统问题解决
ECS新用户专享

ECS新用户专享

阿里云爆款服务器1核2G仅需96.90元/年,2核4G仅需565.80元/年
ECS老用户关怀计划

ECS老用户关怀计划

云服务器ECS老用户升级四重礼遇「 ECS实例规格变配/升级 」、「 实例续费 」、「 带宽升级 」、「 云盘扩容 」享6.5折限时折扣!
阿里云最新优惠活动

阿里云最新优惠活动

上云优惠聚集地『 新老用户同享』

执行composer update 命令提示Fatal error: Allowed memory size of 1610612736 bytes exhausted (tried to allocate 150994944 bytes)

Shadow 发表了文章 • 0 个评论 • 114 次浏览 • 2020-08-11 10:24 • 来自相关话题

官方出品:鸿宇科技
鸿宇论坛:bbs.hongyuvip.com
鸿宇QQ群:90664526
技术QQ号:1527200768
解决方案:php.ini 里默认的 memory_limit 为 128M ,此时执行composer update 命令失败,原因内存不足,修改 php.ini 文件中 memory_limit 为 4096M(或更高) ,再次执行 composer update 更新成功。composer 版本为最新,镜像为阿里云Fatal error: Allowed memory size of 1610612736 bytes exhausted (tried to allocate 150994944 bytes) in phar://D:/Tools/phpstudy_pro/Extensions/composer/composer.phar/src/Composer/DependencyResolver/RuleSet.php on line 90

Check https://getcomposer.org/doc/articles/troubleshooting.md#memory-limit-errors for more info on how to handle out of memory errors.
  查看全部
官方出品:鸿宇科技
鸿宇论坛:bbs.hongyuvip.com
鸿宇QQ群:90664526
技术QQ号:1527200768
解决方案:php.ini 里默认的 memory_limit 为 128M ,此时执行composer update 命令失败,原因内存不足,修改 php.ini 文件中 memory_limit 为 4096M(或更高) ,再次执行 composer update 更新成功。composer 版本为最新,镜像为阿里云
Fatal error: Allowed memory size of 1610612736 bytes exhausted (tried to allocate 150994944 bytes) in phar://D:/Tools/phpstudy_pro/Extensions/composer/composer.phar/src/Composer/DependencyResolver/RuleSet.php on line 90

Check https://getcomposer.org/doc/articles/troubleshooting.md#memory-limit-errors for more info on how to handle out of memory errors.

 

阿里云 Composer 全量镜像

Shadow 发表了文章 • 0 个评论 • 357 次浏览 • 2020-05-07 11:37 • 来自相关话题

全局配置(推荐)

所有项目都会使用该镜像地址:
composer config -g repo.packagist composer https://mirrors.aliyun.com/composer/
取消配置:
composer config -g --unset repos.packagist

项目配置

仅修改当前工程配置,仅当前工程可使用该镜像地址:
composer config repo.packagist composer https://mirrors.aliyun.com/composer/
取消配置:
composer config --unset repos.packagist

调试

composer 命令增加 -vvv 可输出详细的信息,命令如下:
composer -vvv require alibabacloud/sdk

遇到问题?

1. 建议先将Composer版本升级到最新:
composer self-update

2. 执行诊断命令:
composer diagnose

3. 清除缓存:
composer clear

4. 若项目之前已通过其他源安装,则需要更新 composer.lock 文件,执行命令:
composer update --lock
 
阿里云Composer镜像站
  查看全部
全局配置(推荐)

所有项目都会使用该镜像地址:
composer config -g repo.packagist composer https://mirrors.aliyun.com/composer/
取消配置:
composer config -g --unset repos.packagist

项目配置

仅修改当前工程配置,仅当前工程可使用该镜像地址:
composer config repo.packagist composer https://mirrors.aliyun.com/composer/
取消配置:
composer config --unset repos.packagist

调试

composer 命令增加 -vvv 可输出详细的信息,命令如下:
composer -vvv require alibabacloud/sdk

遇到问题?

1. 建议先将Composer版本升级到最新:
composer self-update

2. 执行诊断命令:
composer diagnose

3. 清除缓存:
composer clear

4. 若项目之前已通过其他源安装,则需要更新 composer.lock 文件,执行命令:
composer update --lock
 
阿里云Composer镜像站
 

Composer 设置忽略版本匹配的方法

Shadow 发表了文章 • 0 个评论 • 376 次浏览 • 2020-05-07 11:35 • 来自相关话题

使用:  --ignore-platform-reqs
composer install --ignore-platform-reqs

composer update --ignore-platform-reqs
 
使用:  --ignore-platform-reqs
composer install --ignore-platform-reqs

composer update --ignore-platform-reqs